Drupal7で特定のjQueryのバージョンをjQuery Multiモジュールを使用して指定する

以前書いたようにViewsUIとMasonryを一緒に使おうとすると特定のバージョンのjQueryを指定する必要がある。

Drupal7 Views UI 7.x-3.xとjQuery 1.8以降の互換性

jQuery Updateモジュールは勝手に最新のバージョンにしてしまうためこちらでバージョンを指定できない。

よってjQuery Multiを使うことにした。

このモジュールを使う上で気をつけるべき点は、有効化する前にlibrariesフォルダに読み込みたいバージョンのjQueryのファイルを置く必要があること。

モジュールダウンロード後、sites/all/librariesフォルダ内にjqueryフォルダを作成し、その中に、

jquery-1.x.x.min.js

といった名称でjQueryライブラリファイルを作成する。jqueryの後はハイフンでないとモジュール自体が有効化されないため注意。(要するにjQuery公式サイトで使われているフィアル名と同じにする必要がある。)

詳細はモジュールをダウンロード後モジュール内に含まれるreadmeファイルを参照。